游船出租
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8055 Accepted Submission(s): 2702
Problem Description
现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和
平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。
Input
测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。
Sample Input
1 S 08:10 2 S 08:35 1 E 10:00 2 E 13:16 0 S 17:00 0 S 17:00 3 E 08:10 1 S 08:20 2 S 09:00 1 E 09:20 0 E 17:00 -1
Sample Output
2 196 0 0 1 60
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ull unsingned long long
#define ll long long
#define IN __int64
#define N 110
#define M 1000000007
using namespace std;
struct zz
{
int t;
int v;
}p[N];
int main()
{
int bh,h,m;
char c;
int k=0;
double sum=0;
memset(p,0,sizeof(p));
while(1)
{
scanf("%d",&bh);
if(bh==-1)
break;
getchar();
scanf("%c%d:%d",&c,&h,&m);
if(!bh)
{
if(k)
printf("%d %.lf\n",k,sum/k);
else
printf("0 0\n");
sum=0;k=0;
continue;
}
if(c=='S')
{
p[bh].t=h*60+m;
p[bh].v=1;
}
else
{
if(p[bh].v)
{
sum+=h*60+m-p[bh].t;
k++;p[bh].v=0;
}
}
}
return 0;
}