CodeForces - 675C

Money Transfers


Time Limit:                                                        1000MS                       

 

Memory Limit:                                                        262144KB                       

 

64bit IO Format:                            %I64d & %I64u                       


SubmitStatus


Description



There are n banks in the city where Vasya lives, they are located in a circle, such that any two banks are neighbouring if their indices differ by no more than 1. Also, bank 1 and bank n are neighbours if n > 1. No bank is a neighbour of itself.

Vasya has an account in each bank. Its balance may be negative, meaning Vasya owes some money to this bank.

There is only one type of operations available: transfer some amount of money from any bank to account in any neighbouring

Vasya doesn't like to deal with large numbers, so he asks you to determine the minimum number of operations required to change the balance of each bank account to zero. It's guaranteed, that this is possible to achieve, that is, the total balance of Vasya in all banks is equal to zero.


Input



The first line of the input contains a single integer n (1 ≤ n ≤ 100 000) — the number of banks.

The second line contains n integers ai ( - 109 ≤ ai ≤ 109), the i-th of them is equal to the initial balance of the account in the i-th bank. It's guaranteed that the sum of all ai is equal to 0.


Output



Print the minimum number of operations required to change balance in each bank to zero.


Sample Input



Input



3 5 0 -5



Output



1



Input



4 -1 0 1 0



Output



2



Input



4 1 2 3 -6



Output



3


Sample Output



Hint



Source


Codeforces Round #353 (Div. 2)


//题意:


小明在n个银行中有存款也有欠款,并且存款总和与欠款总和相等,问小明要经过几次周转才能使所有的银行中的钱数都为0,。


Hait:这几个是两两相邻的,并且第一个与最后一个是相邻的,每次周转只能在两个相邻的银行之间进行。


//思路:


因为最终是和为0的,所以用map记录每次输入后的和出现的个数,一直找最小的次数就行了。就是一个思想(起初我也不太懂,但看了大神的代码自己又推了一遍,感觉这思想好厉害)


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<map>
#define INF 0x3f3f3f3f
#define ll long long
#define M 1000000007
#define N 100010
using namespace std;
map<ll,int>mp;
int main()
{
	int n,m;
	while(scanf("%d",&n)!=EOF)
	{
		int ans=n-1;
		ll sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&m);
			sum+=m;
			++mp[sum];
			ans=min(ans,n-mp[sum]);			
		}
		printf("%d\n",ans);
		mp.clear();
	}
	return 0;
}