POJ - 2503
Time Limit: 3000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

Submit Status

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday cat atcay pig igpay froot ootfray loops oopslay atcay ittenkay oopslay

Sample Output

cat eh loops

Hint

Huge input and output,scanf and printf are recommended.
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define N 100010
using namespace std;
char s[20];
int k;
struct zz
{
	char e[20];
	char s[20];
}p[N];
bool cmp(zz a,zz b)
{
	return strcmp(a.s,b.s)<0;
}
int judge(char *s)
{
	int l=0,r=k-1;
	while(l<=r)
	{
		int mid=(l+r)/2;
		if(strcmp(p[mid].s,s)==0)
			return mid;
		else if(strcmp(p[mid].s,s)>0)
			r=mid-1;
		else
			l=mid+1;
	}
	return -1;
}
int main()
{
	k=0;
	char c;
	while(scanf("%s%c",p[k].e,&c)!=EOF)
	{
		if(c=='\n')
		{
			strcpy(s,p[k].e);
			break;
		}
		scanf("%s",p[k++].s);
	}
	sort(p,p+k,cmp);
	int kk=judge(s);
	if(kk>=0)
		printf("%s\n",p[kk].e);
	else
		printf("eh\n");
	while(scanf("%s",s)!=EOF)
	{
		kk=judge(s);
		if(kk>=0)
			printf("%s\n",p[kk].e);
		else
			printf("eh\n");
	}
	return 0;
}