ZOJ - 3875
Time Limit: 2000MS | | Memory Limit: 65536KB | | 64bit IO Format: %lld & %llu |
Description
The 999th Zhejiang Provincial Collegiate Programming Contest will be held in Marjar University. The canteen of Marjar University is making preparations for this grand competition. The canteen provides a lunch set of three types: appetizer, main course and dessert. Each type has several dishes with different prices for choosing.
Edward is the headmaster of Marjar University. One day, to inspect the quality of dishes, he go to the canteen and decides to choose a median set for his lunch. That means he must choose one dish from each of appetizers, main courses and desserts. Each chosen dish should at the median price among all dishes of the same type.
For example, if there are five dessert dishes selling at the price of 2, 3, 5, 10, 30, Edward should choose the dish with price 5 as his dessert since its price is located at the median place of the dessert type. If the number of dishes of a type is even, Edward will choose the dish which is more expensive among the two medians.
You are given the list of all dishes, please write a program to help Edward decide which dishes he should choose.
Input
There are multiple test cases. The first line of input contains an integer T
The first line contains three integers S, M and D (1 <= S, M, D <= 100), which means that there are S dishes of appetizer, M dishes of main course and D
Then followed by three parts. The first part contains S lines, the second and the last part contains M and D
Output
For each test case, output the total price of the median set, together with the names of appetizer, main course and dessert, separated by a single space.
Sample Input
2 1 3 2 Fresh_Cucumber 4 Chow_Mein 5 Rice_Served_with_Duck_Leg 12 Fried_Vermicelli 7 Steamed_Dumpling 3 Steamed_Stuffed_Bun 4 2 3 1 Stir-fried_Loofah_with_Dried_Bamboo_Shoot 33 West_Lake_Water_Shield_Soup 36 DongPo's_Braised_Pork 54 West_Lake_Fish_in_Vinegar 48 Longjing_Shrimp 188 DongPo's_Crisp 18
Sample Output
15 Fresh_Cucumber Fried_Vermicelli Steamed_Stuffed_Bun 108 West_Lake_Water_Shield_Soup DongPo's_Braised_Pork DongPo's_Crisp
Hint
Source
The 12th Zhejiang Provincial Collegiate Programming Contest
//题意:
输入三个数,分别代表三个等级的东西有多少
然后按顺序输入每个东西的名字与质量数字,然后对于每个等级选出其质量为中位数的加起来,最后输出
//思路:水题,直接模拟
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
char s[101];
int val;
}A[200],B[200],C[200];
bool cmp(node s1,node s2)
{
return s1.val<s2.val;
}
int main()
{
int a,b,c;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&a,&b,&c);
for(int i=0;i<a;i++)
scanf("%s%d",&A[i].s,&A[i].val);
for(int i=0;i<b;i++)
scanf("%s%d",&B[i].s,&B[i].val);
for(int i=0;i<c;i++)
scanf("%s%d",&C[i].s,&C[i].val);
sort(A,A+a,cmp);
sort(B,B+b,cmp);
sort(C,C+c,cmp);
int ans=0;
ans=A[a/2].val+B[b/2].val+C[c/2].val;
printf("%d %s %s %s\n",ans,A[a/2].s,B[b/2].s,C[c/2].s);
}
return 0;
}