CodeForces - 673A

Bear and Game


Time Limit:                                                        2000MS                       

 

Memory Limit:                                                        262144KB                       

 

64bit IO Format:                            %I64d & %I64u                       


SubmitStatus


Description



Bear Limak likes watching sports on TV. He is going to watch a game today. The game lasts 90

Each minute can be either interesting or boring. If 15

You know that there will be n interesting minutes t1, t2, ..., tn. Your task is to calculate for how many minutes Limak will watch the game.


Input



The first line of the input contains one integer n (1 ≤ n ≤ 90) — the number of interesting minutes.

The second line contains n integers t1, t2, ..., tn (1 ≤ t1 < t2 < ... tn ≤ 90), given in the increasing order.


Output



Print the number of minutes Limak will watch the game.


Sample Input



Input



3 7 20 88



Output



35



Input



9 16 20 30 40 50 60 70 80 90



Output



15



Input



9 15 20 30 40 50 60 70 80 90



Output



90


Sample Output



Hint



Source


Codeforces Round #351 (VK Cup 2016 Round 3, Div. 2 Edition)


//题意:  小明看电影的原则是:如果悲情剧连续15分钟,他就会关掉电视


给你n个时间点,每个时间点表示在这一分钟电影是喜剧,现在问他最多能看多长时间的电影。


//思路:


直接模拟就行了


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(i=1;i<=n;i++)
		{
			if(a[i]-a[i-1]>15)
				break;
		}
		if(a[i-1]+15<=90)
			printf("%d\n",a[i-1]+15);
		else
			printf("90\n");
	}
	return 0;
}