An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

"X" and " " (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X's.

"X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X's.

Digital-Image View of Surfaces


Left Right

XXXX XXXXX

XXX XXXXXXX

XXXXX XXXX

XX XXXXXX

. .

. .

. .

XXXX XXXX

XXX XXXXXX

1 25



In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

"X" of the left surface of some row is immediately to the left of the leftmost "X"

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set has the following format:


First line -

A single unsigned integer,  N, with value greater than zero (0) and less than 13. The first digit of 

N will be the first character on a line.


Next N lines -

X's, then zero or more spaces, then one or more  X's.

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input (character "B" for ease of reading. The actual input file will use the ASCII-space character, not "B").


4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0


Sample Output


4 0 0


本题为水题,难点在于题意理解。题意为将空格右边的X作为一个整体向左移动,直到不能移动为止(即其中一行空格没有了,两边X接触),所以本题解决方法是求最小空格数量,然后每行减去最小空行数量之和。


#include <stdio.h>
#include <string.h>

int main()
{
    int n, i, j, a[14], min, x, k;
    char s[14][26];
    while(scanf("%d ", &n)!=EOF)
    {
        if(n == 0) break;
        else
        {
            x = 0;
            for(i = 0; i < n; i++)
            {
                a[i] = 0;
                gets(s[i]);
                k = strlen(s[i]);
                for(j = 0; j < k; j++)
                {
                    if(s[i][j] == ' ')
                        a[i]++;
                }
                if(i == 0)
                    min = a[i];
                else
                {
                    if(min > a[i])
                        min = a[i];
                }

            }
            for(i = 0; i < n; i++)
            {
                x = x + a[i] - min;
            }
            printf("%d\n", x);
        }

    }
    return 0;
}