题目描述


按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


输入


第一行输入元素个数n; 
第二行输入n个整数。


输出


第一行输出初始链表元素个数; 
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。


示例输入


10 21 30 14 55 32 63 11 30 55 30


示例输出


10 30 55 30 11 63 32 55 14 30 21 7 30 55 11 63 32 14 21


提示


#include <stdio.h>
#include <stdlib.h>
using namespace std;
struct node
{
    int x;
    struct node *next;
}*head,*a,*b;
int main()
{
    int n, i, s, x = 0;
    scanf("%d",&n);
    printf("%d\n",n);
    for(i = 0; i < n; i++)
    {
        node *q = new node;
        scanf("%d",&q->x);
        q->next=head;
        head=q;
    }
    for(node *p=head;p!=NULL;p=p->next)
    {
        if(x!=n-1)
            printf("%d ",p->x);
        else
            printf("%d\n",p->x);
        x++;
    }
    for(node *p=head;p!=NULL;p=p->next)
    {
        s = p->x;
        a = p;
        b = a->next;
        while(b!=NULL)
        {
            if(b->x==s)
            {
                a->next = b->next;
                delete(b);
                b=a->next;
                n--;
            }
            else
            {
                a = a->next;
                b = a->next;
            }
        }
    }
    printf("%d\n",n);
    for(node *p=head;p!=NULL;p=p->next)
    {
        printf("%d ",p->x);
    }
    return 0;
}