The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input


2 12 -3646397


Sample Output


7 2701


#include <stdio.h>
int main()
{
    int n, i, t, s, m, x, j;
    scanf("%d", &t);
    for(j = 0; j < t; j++)
    {
        s = 0;
        scanf("%d", &n);
        m = n > 0 ? n : -n;
        for(i = 1;;i++)
        {
            s = s + i;
            if(s >= m)
                {x = i;break;}
        }
        if((s - m) % 2 == 0)
            printf("%d\n", x);
            else if((s+x+1-m)%2==0)
                printf("%d\n", x+1);
            else
                printf("%d\n", x+2);
            if(j != t - 1)
                printf("\n");
    }
    return 0;
}