Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 140390    Accepted Submission(s): 32755


Problem Description


Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.


Input


The input will consist of a series of integers n, one integer per line.


Output


For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.


Sample Input


1 100


Sample Output


1 5050

 

Author


 

 

 

package endual;

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
	
		Scanner cin = new Scanner(System.in) ;
		long sum = 0 ;
		int n = 0 ;
		while(cin.hasNextInt()){
			    n = cin.nextInt();
				sum = digui(n) ;
				System.out.println(sum + "\n\n");
		}
	}

	private static long  digui(int n) {
		if (1 == n) {
			return 1 ;
		}
		return n + digui(n-1) ;
	}

}

 

 

不知道是为什么要两个斜杠,我知道这是说明的是换行