题目描述:

1002. A+B for Polynomials (25)

This time, you aresupposed to find A+B where A and B are two polynomials.

Input

Each input filecontains one test case. Each case occupies 2 lines, and each line contains theinformation of a polynomial: K N1 aN1 N2 aN2 ...NK aNK, where K is the number of nonzero terms in the polynomial, Niand aNi (i=1, 2, ..., K) are the exponents and coefficients,respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1<=1000.

Output

For each test caseyou should output the sum of A and B in one line, with the same format as theinput. Notice that there must be NO extra space at the end of each line. Pleasebe accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 03.2

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

 

题目翻译:

 

1002.多项式A与B的和

这次,假设A和B是两个多项式,求A与B的和多项式。

 

输入

每个输入文件包含一个测试实例。每个实例有两行,每行包含一个多项式的信息: K N1 aN1 N2 aN2 ... NK aNK,其中K为多项式中非0项的个数,Ni 和 aNi (i=1, 2, ..., K) 分别为指数和系数。数的范围是1 <= K <= 10,0<= NK < ... < N2 < N1 <=1000。

输出

对于每个测试实例,你需要在一行内输出A与B的和,格式与输入时相同。注意每行的结尾不能有多余的空格。小数精确到一位。

 

样例输入

2 1 2.4 0 3.2
2 2 1.5 1 0.5

样例输出

3 2 1.5 1 2.9 0 3.2

#include<cstdio>
#include<map>
using namespace::std;
map<int,double> s;
int main()
{
int i1,t1;
double t2;
for(int z=0;z<2;z++)
{
scanf("%d",&i1);
for(int i=0;i<i1;i++)
{
scanf("%d%lf",&t1,&t2);
if(s.count(t1)==0)
s[t1]=t2;
else
s[t1]+=t2;
}
}
i1=0;
for(map<int,double>::const_iterator m_it=s.begin();m_it!=s.end();m_it++)
{
if(m_it->second!=0.0&&m_it->second!=-0.0)
i1++;
}
printf("%d",i1);
for(map<int,double>::reverse_iterator m_it=s.rbegin();m_it!=s.rend();m_it++)
{
if(m_it->second!=0.0&&m_it->second!=-0.0)
printf(" %d %.1lf",m_it->first,m_it->second);
}
printf("\n");
return 0;
}