Oulipo
Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. Input The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
Output For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. Sample Input 3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN Sample Output 1
3
0 Source |
计算字串在母串中出现的次数
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<string.h>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<sstream>
#include<time.h>
#include<malloc.h>
using namespace std;
char a[100000500], b[10005000];
int Next[10005000],ans;
void get_next(char b[], int m)
{
int i = 0;
Next[0] = -1;
int j = -1;
while (i<m)
{
if (j == -1 || b[i] == b[j])
{
++i;
++j;
if (b[i] == b[j])
Next[i] = Next[j];
else
Next[i] = j;
}
else
j = Next[j];
}
}
int KMP(char a[], int n, char b[], int m, int Next[], int pos)
{
int i = pos;
int j = 0;
while (i<n&&j<m)
{
if (j == -1 || a[i] == b[j])
{
++i;
++j;
}
else
j = Next[j];
if (j == m)
{
ans++;
j = Next[j];
}
}
return ans;
}
int main()
{
int test, n, m, i, j;
scanf("%d", &test);
while (test--)
{
scanf("%s%s",a,b);
int n = strlen(a);
int m = strlen(b);
get_next(a, n);
ans = 0;
KMP(b, m, a, n, Next, 0);
printf("%d\n",ans);
}
}