Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2

Sample Output

15

题意:  求二维最大子矩阵的和 . 3层循环枚举出正方形大矩阵的子区域矩阵. 这算是个暴力枚举求子矩阵和最大.

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <set>
#include <cstring>
#include <stack>
#include <set>
#include <vector>
#include <queue>
#define Swap(a,b) a ^= b ^= a ^= b
#define pi acos(-1)
#define cl(a,b) memset(a,b,sizeof(a))
using namespace std ;
typedef long long LL;
//const int N = 1e7+10 ;
const int inf = 0x3f3f3f3f;
const int MAX = 105;

int n ;
int a[MAX][MAX] ;
int dp[MAX][MAX] ;
int main()
{

scanf("%d",&n);
for(int i = 0 ; i<n ; i++ ){
for(int j = 0 ; j<n ; j++ ){
cin >>a[i][j] ;
}
}
int maxn = -128 ;
for(int i = 0 ; i<n ; i++){
for(int j = i ; j<n ; j++){
int b = 0 ;
for(int k = 0 ; k<n ; k++){
if(j >i ){
a[i][k]+=a[j][k];
}
if(b>0){
b+=a[i][k] ;
}
else{
b = a[i][k] ;
}
maxn = max(maxn,b) ;
}
}
}
cout<<maxn<<endl;
return 0 ;
}