Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 43737 Accepted: 18249

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3


【分析】
求最小循环节循环了几次
跑一遍失败指针,然后就可以找出最小循环节长度:即为 len-fail[len]
如果 len 是 len-fail[len] 的倍数的话,那么就ok。
要不然就是1了。


【代码】

//poj 2496 Power Strings
#include<iostream>
#include<cstdio>
#include<cstring>
#define fo(i,j,k) for(int i=j;i<=k;i++)
using namespace std;
char s[1000005];
int f[1000005];
int main()
{
while(scanf("%s",s+1))
{
memset(f,0,sizeof f);
if(s[1]=='.') break;
int len=strlen(s+1);
int j=0;
fo(i,2,len)
{
while(j && s[j+1]!=s[i]) j=f[j];
if(s[j+1]==s[i]) j++;
f[i]=j;
}
if(len%(len-f[len])==0) printf("%d\n",len/(len-f[len]));
else printf("1\n");
}
return 0;
}