Glass Beads


Time Limit: 3000MS

 

Memory Limit: 10000K

Total Submissions: 4286

 

Accepted: 2431


Description


Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi


Input


The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.


Output


For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.


Sample Input


4 helloworld amandamanda dontcallmebfu aaabaaa


Sample Output


10 11 6 5


Source

​Central Europe 1998​





【分析】

题意:求一个环形字符串切开以后以哪个位置为首得到的串字典序最小。

本来这个题用后缀数组很好搞嘛...复制一遍粘在原串后面跑一个sa,sa[1]不就是答案嘛= =

然后为了练习SAM,开始脑补这个题怎么做...

SAM的一个性质是,从root开始的每一条路径都对应原串的一个子串,所以我们把字符串复制粘贴一下跑一边SAM,然后从root开始,每一次找字典序最小的儿子,贪心地跑len次出解。




【代码】

//poj 1509 Glass Beads
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mxn=10005;
char s[mxn<<1];
int n,m,T,p,q,np,nq,len,root,tot;
int step[mxn<<1],son[mxn<<1][30],pre[mxn<<1];
inline void sam()
{
int i,j;
np=root=tot=1;
M(step),M(son),M(pre);
fo(i,1,len)
{
int c=s[i]-'a'+1;
p=np;
step[np=(++tot)]=step[p]+1;
while(p && !son[p][c])
son[p][c]=np,p=pre[p];
if(!p)
{
pre[np]=root;
continue;
}
q=son[p][c];
if(step[p]+1==step[q])
pre[np]=q;
else
{
step[nq=(++tot)]=step[p]+1;
fo(j,1,26) son[nq][j]=son[q][j];
pre[nq]=pre[q];
pre[q]=pre[np]=nq;
while(p && son[p][c]==q)
son[p][c]=nq,p=pre[p];
}
}
}
int main()
{
int i,j,l,r,c;
scanf("%d",&T);
while(T--)
{
scanf("%s",s+1);
len=strlen(s+1);
fo(i,1,len) s[len+i]=s[i];
len=len+len;
sam();
len>>=1;
int now=root;
fo(i,1,len)
fo(c,1,26)
if(son[now][c])
{
now=son[now][c];
break;
}
printf("%d\n",step[now]-len+1);
}
return 0;
}