Constructing Roads In JGShining's Kingdom

Problem Description
JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output
For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1

Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

题意:找出连线不相交的最多的城市的个数
2
1 2
2 1
两组数据,不想交,值可能有一个

代码:

# include <iostream>
# include <cstdio>

using namespace std;

int a[500009];
int main(){

int n,m,i,j;
int cnt = 0;
while(scanf("%d",&n)!=EOF){

int temp1,temp2;
for(int i=0;i<n;i++){
scanf("%d%d",&temp1,&temp2);
a[temp1] = temp2;
}
/*
1 2
2 1
*/

int dp[500009];//记住最大的递增子序列
dp[1] = a[1];
int len = 1;//记录个数

for(int i=2;i<=n;i++){

int low =1;//定义这两个变量的目的是记录最大递增子序列
int high = len;
while(low<=high){//注意这里low<high与low<=high的区别
int middle = (low+high)/2;
if(dp[middle]<a[i]) low = middle + 1;
else high = middle - 1;
}
/*
结束循环的时候 low与high的关系
当low>high的时候,说明找到新的元素或替换某个元素(2 3 5 (插入一个4))乃保持递增的序列
当low<high的时候-->对应递减子序列
*/

dp[low] = a[i];//low的位置到底在呢里? --> 递增的序列
if(low>len){//说明有新的元素增加
len++;
}
}
printf("Case %d:\n",++cnt);
if(len==1){
printf("My king, at most %d road can be built.\n\n",len);
}else{
printf("My king, at most %d roads can be built.\n\n",len);
}


}

return 0;
}