Divide Chocolate


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1276    Accepted Submission(s): 607


Problem Description


It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.


hdu 4301 Divide Chocolate(DP ,4级,多校)_ide


To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.


 



Input


First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.


 



Output


For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line. 


 



Sample Input


2
2 1
5 2


 



Sample Output


1
45


 



Author


BUPT


 



Source


​2012 Multi-University Training Contest 1 ​


 



Recommend


zhuyuanchen520


思路:dp1[n][m]前N列分成M份,最后两个分开的情况数

             dp2[n][m]前N列分成M份,最后两个在一起断情况


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long LL;
const int mm=2e3+9;
const LL mod=100000007;
LL dp1[1003][mm],dp2[1003][mm];
int main()
{
memset(dp1,0,sizeof(dp1));///divided
memset(dp2,0,sizeof(dp2));///togather
dp1[1][1]=0;dp1[1][2]=1;
dp2[1][1]=1;dp2[1][2]=0;
for(int i=2;i<=1002;++i)
for(int j=1;j<=i+i;++j)
{
dp1[i][j]=dp1[i-1][j]+dp1[i-1][j-1]*2+dp2[i-1][j-1]*2;
if(j>2)
dp1[i][j]+=dp1[i-1][j-2]+dp2[i-1][j-2];
dp1[i][j]%=mod;
dp2[i][j]=dp1[i-1][j]*2+dp2[i-1][j]+dp1[i-1][j-1]+dp2[i-1][j-1];
dp2[i][j]%=mod;
}
int cas;
while(~scanf("%d",&cas))
{
while(cas--)
{
int a,b;
scanf("%d%d",&a,&b);
printf("%lld\n",(dp1[a][b]+dp2[a][b])%mod);
}
}

}