Description:

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2 1 2 4 1 3 2 1 4 7 2 1 1 2 3 5 3 1 2 3 4 4 4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

给出1-n个点和m条边,求x这个点到其他点和其他所有点到x点的最短距离。有向图

先跑一遍dijstra,求出想点到其他店的距离之和,然后把方向反转这样在跑一遍最后求最大值就是了。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<set>
#include<map>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
const int INF=0x3f3f3f3f;
using namespace std;
int i,j,k;
int n,m,t;
int x,y;
int u,v,w;
int ans,res,cnt,temp,sum;
int dis[1055];
int vis[1055];
int mp[1055][1555];
int a[1055];
void dijkstra(int bg,int en)
{
memset(vis,0,sizeof(vis));
for(int i=1; i<=n; i++)
dis[i]=mp[bg][i];
int minn,pos;
for(int i=1; i<=n; i++)
{
minn=INF;
for(int j=1; j<=n; j++)
{
if(!vis[j]&&dis[j]<minn)
{
pos=j;
minn=dis[j];
}
}
vis[pos]=1;
for(int j=1; j<=n; j++)
{
if(!vis[j])
dis[j]=min(dis[j],dis[pos]+mp[pos][j]);
}
}
for(int i=1; i<=n; i++)
{
a[i]+=dis[i];
}
}
int main()
{
scanf("%d %d %d",&n,&m,&x);
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
{
if(i==j)
mp[i][j]=0;
else
mp[i][j]=INF;
}
memset(a,0,sizeof(a));
while(m--)
{
scanf("%d %d %d",&u,&v,&w);
mp[u][v]=w;
}
dijkstra(x,n);
for(i=1; i<n; i++)
for(j=i+1; j<=n; j++)
swap(mp[i][j],mp[j][i]);
dijkstra(x,n);
sum=0;
for(int i=1; i<=n; i++)
sum=max(sum,a[i]);
cout<<sum<<endl;
}