题目描述:

达达现在碰到了一个棘手的问题,有N个整数需要排序。

达达手头能用的工具就是若干个双端队列。

她从1到N需要依次处理这N个数,对于每个数,达达能做以下两件事:

1.新建一个双端队列,并将当前数作为这个队列中的唯一的数;

2.将当前数放入已有的队列的头之前或者尾之后。

对所有的数处理完成之后,达达将这些队列按一定的顺序连接起来后就可以得到一个非降的序列。

请你求出最少需要多少个双端序列。

输入格式

第一行输入整数N,代表整数的个数。

接下来N行,每行包括一个整数DiDi,代表所需处理的整数。

输出格式

输出一个整数,代表最少需要的双端队列数。

数据范围

1≤N≤2000001≤N≤200000

输入样例:

6
3
6
0
9
6
3

输出样例:

2

我们知道,要满足题目要求的话。每个双端队列里面的序列一定是非降序的。当所有的双端队列合在一起的时候,也是非降序的。那么我们现在可以这样考虑,想象一下,每个双端队列的入队情况。下标最小的值入队,然后后面的数如果比他大 则放右边 反之,放左边。如此,那么这个双端队列的下标序列一定是先递减在递增的序列。称为单谷性质。

我们可以这样理解,一个双端队列能装一个单谷。当这个序列按有序排列的时候,出现了单谷就是几个双端队列。
当有相同元素的时候 需要特殊考虑。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<vector>
#include<math.h>
const int INF = 0x3f3f3f3f;
using namespace std;
typedef long long ll;
typedef double ld;
int i,j,l;
struct duilie
{
ll val,x;
}node[200100];

int cmp(duilie a,duilie b)
{
if(a.val == b.val)
return a.x < b.x;
return a.val < b.val;
}

int main()
{
int n;
scanf("%d",&n);
for(int i = 1; i <= n; i ++)
{
scanf("%lld",&node[i].val);
node[i].x = i;
}
sort(node + 1,node + 1 + n,cmp);
int ans = 1;
int point = 1;
ll pre = 10010101000;
for(int i = 1; i <= n; )
{
int j;
j = i + 1;
while(node[j].val == node[i].val)
j ++;
int mi = node[i].x,ma = node[j - 1].x;
if(point)
{
if(pre > ma)
{
pre = mi;
}
else
{
pre = ma;
point = 0;
}
}
else
{
if(pre < mi)
{
pre = ma;
}
else
{
pre = mi;
point = 1;
ans ++;
}
}
i = j;
}
printf("%d\n",ans);
}