Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving1 K PAdd client K to the waiting list with priority P2Serve the client with the highest priority and drop him or her from the waiting list3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2 1 20 14 1 30 3 2 1 10 99 3 2 2 0

Sample Output

0 20 30 10 0

有 n 个客户,每个客户有一个优先度,我们需要3个操作

1 X Y 加入ID为 X ,优先度为 Y 的客户

2 提取出优先度最大的客户

3 提取出优先度最小的客户

乍一看 感觉堆可以解决, 但是我们发现 不但需要最大,还需要最小,那么我们便用 treap 解决即可。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<iomanip>
#include<math.h>
#include<sstream>
using namespace std;
typedef long long ll;
typedef double ld;
struct Node
{
Node *ch[2];
int r,v,info;//v是顾客优先级,info是顾客的编号,r由rand()生成
Node(int v,int info):v(v),info(info)
{
r=rand();
ch[0]=ch[1]=NULL;
}
int cmp(int x)
{
if(x==v)
return -1;
return x<v? 0:1;
}
};
void rate(Node* &o,int d)
{
Node *k=o->ch[d^1];
o->ch[d^1]=k->ch[d];
k->ch[d]=o;
o=k;
}
void add(Node* &o,int v,int info)
{
if(o==NULL)
o=new Node(v,info);
else
{
int d= v < o->v?0:1;
add(o->ch[d],v,info);
if(o->ch[d]->r > o->r)
rate(o,d^1);
}
}
void rmove(Node *&o,int v)
{
int d=o->cmp(v);
if(d==-1)
{
Node *u=o;
if(o->ch[0] && o->ch[1])
{
int d2 = o->ch[0]->r < o->ch[1]->r ?0:1;
rate(o,d2);
rmove(o->ch[d2],v);
}
else
{
if(o->ch[0]==NULL)
o=o->ch[1];
else
o=o->ch[0];
delete u;
}
}
else
rmove(o->ch[d],v);
}
int find_max(Node *o)//找到最大v值
{
if(o->ch[1]==NULL)
{
printf("%d\n",o->info);
return o->v;
}
return find_max(o->ch[1]);
}
int find_min(Node *o)//找到最小v值
{
if(o->ch[0]==NULL)
{
printf("%d\n",o->info);
return o->v;
}
return find_min(o->ch[0]);
}
int main()
{
int op;
Node *root=NULL;
while(scanf("%d",&op)==1&&op)
{
if(op==1)
{
int info,v;
scanf("%d%d",&info,&v);
add(root,v,info);
}
else if(op==2)
{
if(root==NULL)
{
printf("0\n");
continue;
}
int v=find_max(root);
rmove(root,v);
}
else if(op==3)
{
if(root==NULL)
{
printf("0\n");
continue;
}
int v=find_min(root);
rmove(root,v);
}
}
return 0;
}