Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

题意:

一个大学有n个计算机,给出每台计算机连接需要的流量存放到一个矩阵,吧计算机划分为两个子网,使组间流量最大。

开始先将所有节点放在同一组,然后逐个向另一组中添加节点,添加节点到另一组时要注意权值的变化,即应加上原来的组里的所有节点的权值,减去当前组里所有节点的权值,然后记录当前的最大权值并进行下一步搜索,注意将分组标识清除。

代码如下:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
using namespace std;
int c[25][25];
int vis[25];
int ans,n,m;
void dfs(int x,int weight)
{
vis[x]=1;
int temp=weight;
for(int i=0;i<n;i++)
{
if(vis[i]==0)
temp+=c[x][i];
else
temp-=c[x][i];
}
ans=max(temp,ans);
for(int i=x+1;i<n;i++)
{
if(temp>weight)
{
dfs(i,temp);
vis[i]=0;
}
}
}

int main()
{
int i,j,k;
while(~scanf("%d",&n)&&n)
{
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
scanf("%d",&c[i][j]);
}
}
memset(vis,0,sizeof(vis));
ans=0;
dfs(0,0);
printf("%d\n",ans);
}
return 0;
}