7-28 单词替换 (20 分)

设计一个对字符串中的单词查找替换方法,实现对英文字符串中所有待替换单词的查找与替换。

输入格式:

首行输入母字符串,第二行输入查询的单词,第三行输入替换后的单词。

输出格式:

完成查找替换后的完整字符串

输入样例:

在这里给出一组输入。例如:

Although I am without you, I will always be ou you
ou
with

输出样例:

在这里给出相应的输出。例如:

Although I am without you, I will always be with you

参考答案

import java.util.*;

class Main{
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
String str_book = cin.nextLine();
String str_old = cin.next();
String str_new = cin.next();

String []book_str = str_book.split(" ");

for( int i = 0; i < book_str.length; i ++ ){
String str = book_str[i];
if( str.equals(str_old) || str.equals(str_old + ",") || str.equals(str_old + ".") || str.equals(str_old + "'")){
if(! (str.charAt(str.length() - 1) >= 65 && str.charAt(str.length() - 1) <= 122) ){
str = str_new + str.charAt(str.length() - 1);

}
else{
str = str_new ;
}

}
if( i != book_str.length - 1){
System.out.print(str + " ");
}
else{
System.out.println(str);
}
}

cin.close();
}
}