7-47 古风排版 (20分)

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:
输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:
按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:

4
This is a test case

输出样例:

asa T
st ih
e tsi
ce s

参考代码

#include <stdio.h>
#include <string.h>

int main()
{
char s[1001] = {0};
int n, cnt = 0, i, j, jj;

scanf("%d", &n);
getchar();
gets(s);

int len = strlen(s);

int k;
if (len % n)
k = (len / n) + 1;
else
k = len / n;
i = k * n - n;
int t = i;
for (j = 0; j < n; ++j)
{
i = t + j;
for (jj = 0; jj < k; ++jj)
{
if (i < len)
{
printf("%c", s[i]);
}
else
printf(" ");
i -= n;
}
printf("\n");
}

return 0;
}