Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input


 


3 2

 

Sample Output


 


+---+ | | | | +---+

代码:

#include<stdio.h>
#include<string.h>
int main()
{
int n,m,i,j;
char a[1000][1000];
while(scanf("%d %d",&n,&m)!=EOF)
{
for (i=0;i<n+m;i++)
for (j=0;j<m+n;j++)
a[i][j]=' ';//先全部打成空格,再变
a[1][1]='+';
a[1][2+n]='+';
for(j=2;j<n+2;j++)
{
a[1][j]='-';
}
for(i=1;i<=n+2;i++)
{
a[m+2][i]=a[1][i];
}
for(j=2;j<m+2;j++)
{
a[j][1]='|';
a[j][n+2]='|';
}
for(i=1;i<=m+2;i++)
{
for(j=1;j<=n+2;j++)
{
printf("%c",a[i][j]);//这是%c,不要写错
}
printf("\n");
}
printf("\n");
}
return 0;
}

用二维数组稍微麻烦,不用数组或用一维数组也可以做。

#include<string.h>
memset(a,0,sizeof(a));//这是使数组中的数据清零