Alignment of Code

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 958    Accepted Submission(s): 230
Problem Description

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p 1 = 1; the second words on each line are printed at the minimal possible position p 2, such that all first words end at or before position p 2 - 2; the third words on each line are printed at the minimal possible position p 3, such that all second words end at or before position p 3 - 2, etc.
For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).


 



Input


The input begins with an integer T. The next T blocks each represents a case. Each case contains one or more lines of the code up to the end of case mark-a single '@' in a single line. All lines are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines for each case.


 



Output


For each case, write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position p i.


 



Sample Input


1
start: integer; // begins here
stop: integer; // ends here
s: string;
c: char; // temp
@


 



Sample Output


start: integer; // begins here
stop: integer; // ends here
s: string;
c: char; // temp


【分析】

       以空格为界将每行中的每个“词”储存起来,由于每行的“词”不定,所以用链表进行储存(当然也可以用数组,只要数组的大小足够大),那么每一行形成一个链表,就有多个链表,构成一个数组。在读取“词”的过程中,记录每一列中“词”最大的长度。记录在一个链表中(这个链表的每个元素是输入文本的每一列词最大长度的值)。

/*
java中字符串的split方法的参数含义:
public String[] split(String regex)根据给定的正则表达式的匹配来拆分此字符串.split("\\s+") 中
\\s表示 空格,回车,换行等空白符,
+号表示一个或多个的意思*/

用java语言编写程序,代码如下:


import java.util.ArrayList;
import java.util.Scanner;
//终于对了~~~!!注意格式问题!!
public class Main {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
int t = input.nextInt();
input.nextLine();//注意读取回车符。这是我第二次吃大亏了!!!

for(int ti = 0; ti < t; ti++) {
ArrayList<String>[] list = new ArrayList[1001];
ArrayList<Integer> colsMaxLen = new ArrayList<Integer>();
for(int i = 0; i < 1001; i++) {
list[i] = new ArrayList<String>();
colsMaxLen.add(0);
}

String s;
String[] tempArr;
int arrLen = 0;
int line = 0;
while(true) {
s = input.nextLine();
if(s.equals("@"))
break;

tempArr = s.split("\\s+");
//上述正则表达式中 \\s表示 空格,回车,换行等空白符,+号表示一个或多个的意思,

arrLen = tempArr.length;
int first = 0;
//为什么要有下面的语句的呢?理由是用split切割时,字符串前面有空格的话,似乎会多切出一个空字符,那么这个空字符就应该省略
if(tempArr[0].equals(""))
first = 1;

for(int pos = 0; first < arrLen; first++, pos++) {
list[line].add(tempArr[first]);
if(colsMaxLen.get(pos) < tempArr[first].length())
colsMaxLen.set(pos, tempArr[first].length());
}

line++;
}

print(line, list, colsMaxLen);
}

}

public static void print(int line, ArrayList<String>[] list, ArrayList<Integer> colsMaxLen) {
for(int i = 0; i < line; i++) {
for(int j = 0; j < list[i].size() - 1;j++) {
//printWord(list[i].get(j), colsMaxLen.get(j), j);
if(j != 0)
System.out.print(" ");
System.out.printf("%-" + colsMaxLen.get(j) + "s", list[i].get(j));
}
//注意最后每一行最后一个“词”不用进行格式化,而是直接输出回车就行。
if(list[i].size() != 1)
System.out.print(" ");
System.out.println(list[i].get(list[i].size() - 1));
}
}

/*public static void printWord(String s, int len, int cols) {
if(cols != 0)
System.out.print(" ");
System.out.print(s);
for(int i = 0; i < len - s.length(); i++)
System.out.print(" ");
}*/
}