Digit Counting

Time limit: 3.000 seconds

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 toN (1 < N < 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, withN = 13, the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N.

Output

For each test case, write sequentially in one line the number of digit 0, 1,...9

Sample Input


2 3 13


Sample Output


0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1


数数字

       把前n(n<10000)个整数顺次写在一起:123456789101112……数一数 0 ~ 9 各出现多少次(输出10个整数,分别是0,1,……,9出现的次数。

【分析】

       (分析过程附加在程序注释中)

用java语言编写程序,代码如下:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
//先是把所有的结果都计算出来
int[][] digitCount = getDigitCount();

Scanner input = new Scanner(System.in);
int T = input.nextInt();
for(int i = 0; i < T; i++) {
int n = input.nextInt();
for(int j = 0; j < 9; j++)
System.out.print(digitCount[n][j] + " ");
System.out.println(digitCount[n][9]);
}
}

//求前n个整数顺次写在一起后 0 ~ 9各出现多少次。答案在二维数组的第n行中。
public static int[][] getDigitCount() {
int[][] digitCount = new int[10001][10];

//前0个整数顺次写在一起后 0 ~ 9各出现0次
for(int i = 0; i < 10; i++)
digitCount[0][i] = 0;

for(int i = 1; i <= 10000; i++) {
//知道前 n-1 个整数的结果,只要再加上 n 这个数内0~9各出现的次数即为前n个整数的结果
for(int j = 0; j < 10; j++)
digitCount[i][j] = digitCount[i - 1][j];

getNumCounting(digitCount, i, i);
}
return digitCount;
}

//计算每个数内0~9各出现的次数
private static void getNumCounting(int[][] arr, int i, int n) {
int digit = 0;
while(n > 0) {
digit = n % 10;
n /= 10;
arr[i][digit]++;
}
}
}