Rails

Time limit: 3.000 seconds

Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. Thestation was built in last century. Unfortunately, funds were extremely limited that time. It waspossible to establish only a surface track. Moreover, it turned out that the station could be only adead-end one (see picture) and due to lack of available space it could have only one track.





The local tradition is that every train arriving from the direction A continues in the directionB with coaches reorganized in some way. Assume that the train arriving from the direction A has

coaches numbered in increasing order

.The chief for train reorganizationsmust know whether it is possible to marshal coaches continuing in the direction B so that theirorder will be

.Help him and write a program that decides whether it is possible toget the required order of coaches. You can assume that single coaches can be disconnected from thetrain before they enter the station and that they can move themselves until they are on the trackin the direction B. You can also suppose that at any time there can be located as many coaches asnecessary in the station. But once a coach has entered the station it cannot return to the track inthe direction A and also once it has left the station in the direction B it cannot return back to thestation.

Input

The input file consists of blocks of lines. Each block except the last describes one train andpossibly more requirements for its reorganization. In the first line of the block there is the integer

N described above. In each of the next lines of the block there is a permutation of

Thelast line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the inputfile. A line of the output file contains Yes if it is possible to marshal the coaches in the orderrequired on the corresponding line of the input file. Otherwise it contains No. In addition, there isone empty line after the lines corresponding to one block of the input file. There is no line in theoutput file corresponding to the last ``null'' block of the input file.

Sample Input


51 2 3 4 55 4 1 2 3 0 6 6 5 4 3 2 1 0 0


Sample Output


YesNoYes

【分析】

       用栈模拟火车站,栈内的元素是车厢的编号。通过模拟所给的出栈顺序来判断该顺序是否可以成立。

用C++语言编写程序,代码如下:


#include<iostream>
#include<stack>
using namespace std;

const int maxn = 1000 + 10;
int n,target[maxn];

int main() {
while (cin >> n) {
if (n == 0) break;
while (cin >> target[1]) {
if (target[1] == 0)
break;

for (int i = 2; i <= n; i++)
cin >> target[i];

stack<int> s;
int ok = 1;
int A = 1, B = 1; //A指向未进站的车厢编号,B指向出栈顺序的当前编号
while (B <= n) {
//如果A与target[B]相等,说明A编号可以进站之后立即出站
if (A == target[B]) { A++; B++; }
//如果A不能进站后立即出站,再判断站内栈顶车厢是否可以出站,能出站的前提是与当前B编号相等
else if (!s.empty() && s.top() == target[B]) {
s.pop(); B++;
}
//如果前两者情况均不成立的话,那么直接让A编号的车厢进站
else if (A <= n) {
s.push(A++);
}
else {
ok = 0;
break;
}
}
cout << (ok ? "Yes" : "No") << endl;
}
cout << endl;
}
return 0;
}


用java语言编写程序,代码如下:


import java.util.Scanner;
import java.util.Stack;

public class Main {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
final int maxn = 1000 + 10;
int[] target = new int[maxn];

while(input.hasNext()) {
int n = input.nextInt();
if(n == 0) break;
while(input.hasNext()) {
target[1] = input.nextInt();
if(target[1] == 0) break;

for(int i = 2; i <= n; i++)
target[i] = input.nextInt();

int A = 1, B = 1;
boolean ok = true;
Stack<Integer> s = new Stack<Integer>();
while(B <= n) {
if(A == target[B]) {
A++;
B++;
}
else if(!s.isEmpty() && s.peek() == target[B]) {
s.pop();
B++;
}
else if(A <= n) {
s.push(A++);
}
else {
ok = false;
break;
}
}
System.out.println((ok ? "Yes" : "No"));
}
System.out.println();
}
}
}