Organize Your Train part II


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 8394

 

Accepted: 2402


Description


RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.

POJ 3007Organize Your Train part II(水题)_字符串


Figure 1: Layout of the exchange lines

A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):


[3:1] abc+d cba+d d+abc d+cba [2:2] ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba [1:3] a+bcd a+dcb bcd+a dcb+a


Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.


Input


The entire input looks like the following.

the number of datasets = m
1st dataset
2nd dataset

...
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.


Output


For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.


Sample Input


4aa abba abcd abcde


Sample Output


16 12 18


题意:给一个字符串,将这个字符串分成两部分,并将这两部分逆序,即一个字符串得到四个小串s1, s11(s1的逆序), s2, s22(s2的逆序),然后组合,有8种:

s1s2, s1s22, s11s2, s11s22, s2s1, s2s11, s22s1, s22s11。查找有多少不同的。

用map会超时,只能自己动手写hash,就是麻烦点。

#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

char str[100];
int sum;
char hash1[100000][100];

int judge(char a[], char b[])
{
char s[200];
strcpy(s,a);
strcat(s,b);
for(int i = 0; i < sum; i++)
{
if(strcmp(s, hash1[i]) == 0)
return 0;
}
return 1;
}
int main()
{
int j, k, i;
int n;
scanf("%d\n", &n);
while(n--)
{
scanf("%s", str);
int len = strlen(str);
sum = 0;
for(i = 1; i < len; i++)
{
char s1[200];
k = 0;
for(j = 0; j < i; j++)
{
s1[k++] = str[j];
}
s1[k] = '\0';
char s11[200] ;
k = 0;
for(j = i-1; j >= 0; j--)
{
s11[k++] = str[j];
}
s11[k]='\0';
char s2[200] ;
k = 0;
for(j = i; j < len; j++)
{
s2[k++] = str[j];
}
s2[k] = '\0';
char s22[200] ;
k = 0;
for(j = len-1; j >= i; j--)
{
s22[k++] = str[j];
}
s22[k] = '\0';

//printf("%s %s %s %s\n", s1, s11, s2, s22);

if(judge(s1,s2)==1)
{
strcpy(hash1[sum],s1);
//printf("%s ", hash1[sum]);
strcat(hash1[sum],s2);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s1,s22))
{
strcpy(hash1[sum],s1);
strcat(hash1[sum],s22);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s11,s2))
{
strcpy(hash1[sum],s11);
strcat(hash1[sum],s2);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s11,s22))
{
strcpy(hash1[sum],s11);
strcat(hash1[sum],s22);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s2,s1))
{
strcpy(hash1[sum],s2);
strcat(hash1[sum],s1);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s2,s11))
{
strcpy(hash1[sum],s2);
strcat(hash1[sum],s11);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s22,s1))
{
strcpy(hash1[sum],s22);
strcat(hash1[sum],s1);
//printf("%s\n",hash1[sum]);
sum++;
}
if(judge(s22,s11))
{
strcpy(hash1[sum],s22);
strcat(hash1[sum],s11);
//printf("%s\n",hash1[sum]);
sum++;
}
}
printf("%d\n", sum);
}
return 0;
}