Description



Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.


Input



The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100


Output



For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.


Sample Input



3235


Sample Output



NoNoYes0.000000 0.525731-0.500000 0.162460-0.309017 -0.4253250.309017 -0.4253250.500000 0.162460

Hint



This problem is special judge.

构造满足条件的多边形,事实上只要四个点即可满足条件。

#include<cstdio>
#include<queue>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
const int maxn = 35;
int T, n;

int main()
{
scanf("%d", &T);
for (int cas = 1; cas <= T; cas++)
{
scanf("%d", &n);
if (n <= 3) printf("No\n");
else
{
printf("Yes\n");
printf("%.6lf %.6lf\n", 0.0, 0.0);
printf("%.6lf %.6lf\n", -0.5, sqrt(3.0) / 2);
printf("%.6lf %.6lf\n", 0.5, sqrt(3.0) / 2);
for (int i = 4; i <= n; i++)
{
printf("%.6lf %.6lf\n", 0.0, 1.0);
}
}
}
return 0;
}