Description


Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!


Input



The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.


Output



For each test case, output the minimum number we can get after no more than M operations.


Sample Input


3


9012 0



9012 1




9012 2


Sample Output



9012




1092




1029





可以交换数字的两个位置,给定交换的次数,求最小的数字是多少。



这题可以做到nlogn的,不过数据挺水的,直接你n^2跑就能过



#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<stack>
#include<cmath>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int maxn=1e5+10;
int T,n;
char s[maxn];

int main()
{
scanf("%d",&T);
while (T--)
{
scanf("%s%d",s,&n);
for (int i=0;s[i]&&n;i++)
{
if (i)
{
int k=i;
for (int j=i+1;s[j];j++)
{
if (s[j]<=s[k]) k=j;
}
if (s[k]!=s[i])
{
swap(s[k],s[i]);
n--;
}
}
else
{
int k=i;
for (int j=i+1;s[j];j++)
{
if (s[j]!='0'&&s[j]<=s[k]) k=j;
}
if (s[k]!=s[i])
{
swap(s[k],s[i]);
n--;
}
}
}
printf("%s\n",s);
}
return 0;
}