Problem Description


CRB is now playing Jigsaw Puzzle.
There are  N kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most  M pieces? (Two patterns  P and  Q are considered different if their lengths are different or there exists an integer  j such that  j-th piece of  P is different from corresponding piece of  Q.)


Input


T, indicating the number of test cases. For each test case:
The first line contains two integers  N,  M denoting the number of kinds of pieces and the maximum number of moves.
Then  N lines follow.  i-th line is described as following format.
k  a1 a2 ... ak
Here  k is the number of kinds which can be assembled to the right of the  i-th kind. Next  k integers represent each of them.
1 ≤  T ≤ 20
1 ≤  N ≤ 50
1 ≤  M ≤  105
0 ≤  k ≤  N
1 ≤  a1 <  a2 < … <  ak ≤ N


Output


For each test case, output a single integer - number of different patterns modulo 2015.


Sample Input


1
3 2
1 2
1 3
0

 


Sample Output

Hint

possible patterns are ∅, 1, 2, 3, 1→2, 2→3




找到递推式,来一发矩阵乘法就ok了

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cstdio>
#include<ctime>
#include<vector>
using namespace std;
const int base = 2015;
const int maxn = 100005;
int T, n, m, k, kk;

struct Matrix
{
#define size 55
int m[size][size];
Matrix() { memset(m, 0, sizeof(m)); }

void operator =(const Matrix&b) { memcpy(m, b.m, sizeof(m)); }

Matrix operator *(const Matrix&b) {
Matrix c;
for (int i = 0; i < size; i++)
for (int j = 0; j < size; j++)
for (int k = 0; k < size; k++)
c.m[i][k] = (c.m[i][k] + m[i][j] * b.m[j][k]) % base;
return c;
}
Matrix get(int x)
{
Matrix a, b = *this;
for (int f = 0; x; x >>= 1)
{
if (x & 1)
if (f) a = a * b; else a = b, f = 1;
b = b * b;
}
return a;
}
};

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d%d", &n, &m);
Matrix a, b;
for (int i = 1; i <= n + 1; i++) a.m[i][n + 1] = 1;
for (int i = 1; i <= n; i++)
{
scanf("%d", &k);
for (int j = 1; j <= k; j++)
{
scanf("%d", &kk);
a.m[i][kk] = 1;
}
}
for (int i = 1; i <= n + 1; i++) b.m[1][i] = 1;
a = a.get(m);
b = b * a;
if (m == 1) printf("%d\n", n + 1);
else printf("%d\n", b.m[1][n + 1]);
}
return 0;
}