During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones. 

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately! 

Input The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event. 


There are three different events described in different format shown below: 


D x: The x-th village was destroyed. 


Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself. 


R: The village destroyed last was rebuilt. 

Output Output the answer to each of the Army commanders’ request in order on a separate line. 

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4

Sample Output

1
0
2
4



题意:

三种操作:1.d   x 代表破坏 x 点。

有两种方法,一种用线段树,一种用set,第一次做区间合并,写得很丑(第二种方法代码很短)。

方法一:线段树


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stack>
using namespace std;
const int mx = 5e4 + 5;
struct node{
int l, r;
int ls, rs, ms;
}a[4 * mx];
void build(int l, int r, int rt){
a[rt].l = l;
a[rt].r = r;
a[rt].ls = a[rt].rs = a[rt].ms = r - l + 1;
if(l != r){
int mid = (l + r) / 2;
build(l , mid, 2 * rt);
build(mid + 1, r, 2 * rt +1);
}
}
void des(int ro, int p, int ju){
int l = a[ro].l, r = a[ro].r;
if(l == r){
if (ju == 1) a[ro].ls = a[ro].rs = a[ro].ms = 1;
else a[ro].ls = a[ro].rs = a[ro].ms = 0;
return ;
}
int mid = (l + r) / 2;
if (p <= mid)
des(2 * ro, p, ju);
else
des(2 * ro + 1, p, ju);
a[ro].ls = a[2 * ro].ls;
a[ro].rs = a[2 * ro + 1].rs;
a[ro].ms = max(max(a[2 * ro].ms, a[2 * ro + 1].ms), a[2 * ro].rs + a[2 * ro + 1].ls);

if(a[2 * ro].r - a[2 * ro].l + 1 == a[2 * ro].ls)
a[ro].ls += a[2 * ro + 1].ls;
if(a[2 * ro + 1].r - a[2 * ro + 1].l + 1 == a[2 * ro + 1].rs)
a[ro].rs +=a[2 * ro].rs;//rs写成r

}
int que(int ro, int p){
if(a[ro].ms == 0 || a[ro].l == a[ro].r || a[ro].ms == a[ro].r - a[ro].l + 1)
return a[ro].ms;
int mid = (a[ro].l + a[ro].r) / 2;//准备替换
if(p <= mid){
if(p >= a[2 * ro].r - a[2 * ro].rs + 1)
return que(2 * ro , p)+que(2 * ro + 1, mid + 1);
else return que(2 * ro, p);
}
else {
if(p <= a[2 * ro + 1].l + a[2 * ro + 1].ls - 1)
return que(2 * ro, mid) + que(2 * ro + 1, p);
else return que (2 * ro + 1, p);
}
}
int main(){
int n, m, x;
char cmd;
stack <int> s;
while(scanf("%d%d",&n,&m) != EOF){
build(1, n, 1);
while(m--){
getchar();
scanf("%c", &cmd);
if(cmd == 'D') {
scanf("%d", &x);
des(1, x, 0);
s.push(x);
}
else if(cmd == 'R'){
if(!s.empty()){
x = s.top();
s.pop();
des(1, x, 1);
}
}
else {
scanf("%d", &x);
printf("%d\n", que(1, x));
}
}
}
return 0;
}


方法二:set


#include<iostream>
#include<cstdio>
#include<stack>
#include<set>
using namespace std;
set<int> st;
stack<int> sk;
int main(){
int n, m,x;
char cmd;
while(scanf("%d%d",&n, &m) != EOF){
while(!sk.empty()) sk.pop();
st.clear();
st.insert(0);
st.insert(n + 1);
while(m--){

getchar();
scanf("%c", &cmd);
if(cmd == 'D'){
scanf("%d", &x);
sk.push(x);
st.insert(x);
}
else if(cmd == 'R'){

if(!sk.empty()){
x = sk.top();
sk.pop();
if(st.count(x) != 0)
st.erase(x);
}
}
else {
scanf("%d",&x);
set<int>::iterator l, r;
if(st.count(x) != 0) puts("0");
else{
//l = st.lower_bound(x);
l = r = st.upper_bound(x);
l --;
printf("%d\n", *r - *l - 1);
}
}
}
}


return 0;
}