题目描述
This problem is quiet easy.
Initially, there is a string A.

Then we do the following process infinity times.
A := A + “HUSTACM” + A

For example, if a = “X”, then
After 1 step, A will become “XHUSTACMX”
After 2 steps, A will become “XHUSTACMXHUSTACMXHUSTACMX”

Let A = “X”, Now I want to know the characters from L to R of the final string.
输入
Multiple test cases, in each test case, there are only one line containing two numbers L and R.
1 <= L <= R <= 10^12
R-L <= 100
输出
For each test case, you should output exactly one line which containing the substring.
样例输入
5 10
样例输出
TACMXH

#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>

using namespace std;
long long int l,r;
char a[9];
int main()
{
a[0]='H';
a[1]='U';
a[2]='S';
a[3]='T';
a[4]='A';
a[5]='C';
a[6]='M';
a[7]='X';
while(scanf("%lld%lld",&l,&r)!=EOF)
{
int pos;
if(l==1)
pos=7;
else
pos=(l-2)%8;
int cnt=1;
while(cnt<=(r-l)+1)
{
printf("%c",a[(pos)%8]);
pos++;
cnt++;
}
printf("\n");


}
return 0;
}