PAT 1002 A+B for Polynomials
原创
©著作权归作者所有:来自51CTO博客作者wx634e39bb59725的原创作品,请联系作者获取转载授权,否则将追究法律责任
1002. A+B for Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <vector>
#include <strstream>
#include <map>
using namespace std;
double b[1005];
int tag[1005];
int a[45];
int k;
int main()
{
scanf("%d",&k);
int x;double y;
int cnt=0;
memset(tag,0,sizeof(tag));
for(int i=1;i<=k;i++)
{
scanf("%d",&x);
scanf("%lf",&y);
if(!tag[x])
{
b[x]=y;
a[cnt++]=x;
tag[x]=1;
}
else
b[x]+=y;
}
scanf("%d",&k);
for(int i=1;i<=k;i++)
{
scanf("%d%lf",&x,&y);
if(!tag[x])
{
b[x]=y;
a[cnt++]=x;
tag[x]=1;
}
else
b[x]+=y;
}
sort(a,a+cnt);
int num=0,num2;
for(int i=cnt-1;i>=0;i--)
if(b[a[i]]!=0) {num++;num2=i;}
if(num==0)
printf("%d\n",num);
else
printf("%d ",num);
for(int i=cnt-1;i>=0;i--)
{
if(b[a[i]]==0)
continue;
if(i==num2)
printf("%d %.1f\n",a[i],b[a[i]]);
else
printf("%d %.1f ",a[i],b[a[i]]);
}
return 0;
}