Ancient Printer



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 1664    Accepted Submission(s): 807


Problem Description


The contest is beginning! While preparing the contest, iSea wanted to print the teams' names separately on a single paper.
Unfortunately, what iSea could find was only an ancient printer: so ancient that you can't believe it, it only had three kinds of operations:

● 'a'-'z': twenty-six letters you can type
● 'Del': delete the last letter if it exists
● 'Print': print the word you have typed in the printer

The printer was empty in the beginning, iSea must use the three operations to print all the teams' name, not necessarily in the order in the input. Each time, he can type letters at the end of printer, or delete the last letter, or print the current word. After printing, the letters are stilling in the printer, you may delete some letters to print the next one, but you needn't delete the last word's letters.
iSea wanted to minimize the total number of operations, help him, please.



Input


There are several test cases in the input.

Each test case begin with one integer N (1 ≤ N ≤ 10000), indicating the number of team names.
Then N strings follow, each string only contains lowercases, not empty, and its length is no more than 50.

The input terminates by end of file marker.


 



Output


For each test case, output one integer, indicating minimum number of operations.


 


Sample Input


2 freeradiant freeopen



Sample Output


Hint

The sample's operation is:

f-r-e-e-o-p-e-n-Print-Del-Del-Del-Del-r-a-d-i-a-n-t-Print


 



Author


iSea @ WHU



Source


​2010 ACM-ICPC Multi-University Training Contest(3)——Host by WHU​



Recommend


zhouzeyong   |   We have carefully selected several similar problems for you:   ​​3463​​​  ​​​3468​​​  ​​​3467​​​  ​​​3466​​​  ​​​3465​​ 


代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;

const int maxn=1e4;
string s[maxn+5];

int get(int x,int y)
{
int i=0,k=min(s[x].length(),s[y].length());
while(i<k && s[x][i]==s[y][i])i++;
return s[x].length()-i+s[y].length()-i+1;
}

int main()
{
// freopen("1.in","r",stdin);

int n,i,j,ans,len;
while(scanf("%d",&n)==1)
{
for(i=0;i<n;i++)cin>>s[i];
sort(s,s+n),ans=(len=s[0].length())+1;
for(i=1;i<n;i++)ans+=get(i,i-1),len=max(len,j=s[i].length());
printf("%d\n",ans+s[n-1].length()-len);
}
return 0;
}