1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

既是二叉树查找树,又是完全二叉树  完全BST,那么构造的时候就要注意了,看似很难,但其实抓住BST一个很美的性质,就没有难度了,这个美妙的性质就是“BST的中序序列一定有序”。而N结点总数确定了,完全二叉树的结构便确定了,一个数组即可,遍历时右子树直接写2*root+1,左子树直接写2*root即可

注意完全二叉树静态存储时下标必须从1开始

#include<bits/stdc++.h>
using namespace std;
int data[1010],N;
//完全二叉树 静态存储 孩子也确定,于是vector都不用 一个数组即可
int Node[1010];
//中序遍历
int num=1;//1开始 别忘了
void inOrder(int root){
if(root>N) return;
inOrder(2*root);//左子树
Node[root]=data[num++];//访问根 根据中序顺序依次从小到大赋值即可
inOrder(2*root+1);//右子树
}
int main(){
// freopen("in.txt","r",stdin);
cin>>N;//编号1~N
for(int i=1;i<=N;i++) scanf("%d",&data[i]);
sort(data+1,data+N+1);
inOrder(1);//1为根 静态存储必须如此,不然0开始右子树2*0一直是0
for(int i=1;i<=N;i++){
if(i>1) printf(" ");
printf("%d",Node[i]);
}
return 0;
}