1055 The World's Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M(≤100) - the maximum number of outputs, and [​​Amin​​​, ​​Amax​​] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line ​​Case #X:​​​ where ​​X​​​ is the query number starting from 1. Then output the M richest people with their ages in the range [​​Amin​​​, ​​Amax​​]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output ​​None​​.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

原本以为要用树状数组,所以先写个暴力,然后再改,没想到浙大很仁慈,数据很弱,(估计没有10^5个3000次的查询)。全部用cin,cout都过了  450ms差点500ms了。。。看来数据结构之外的PAT甲级都不怎么涉及了

#include<bits/stdc++.h>
using namespace std;
struct RichMan{
string name;
int age,worth;
}man[100010];
int N,K,M,a,b;//N个人 K次查询 查询前M个 [a,b]查询年龄范围
bool compare(RichMan r1,RichMan r2){
if(r1.worth!=r2.worth) return r1.worth>r2.worth;
if(r1.age!=r2.age) return r1.age<r2.age;
return r1.name<r2.name;
}

int main(){
//freopen("in.txt","r",stdin);
cin>>N>>K;
for(int i=0;i<N;i++){
cin>>man[i].name>>man[i].age>>man[i].worth;
}
sort(man,man+N,compare);
int Count=1;
while(K--){
cin>>M>>a>>b;
int num=0;
for(int i=0;i<N;i++){
if(man[i].age>=a&&man[i].age<=b){
if(num==0) cout<<"Case #"<<Count++<<":\n";
cout<<man[i].name<<" "<<man[i].age<<" "<<man[i].worth<<endl;
num++;
if(num==M) break;
}
}

if(num==0){//没有该年龄段的人
cout<<"Case #"<<Count++<<":\nNone\n";
}

}

return 0;
}