1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of ​​Galleon.Sickle.Knut​​​ (​​Galleon​​​ is an integer in [0,10​7​​], ​​Sickle​​​ is an integer in [0, 17), and ​​Knut​​ is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

//进制转换这块pat都是简单题 

#include<iostream>
#include<stdio.h>
using namespace std;

//自己输出变量 不打断点 太浪费时间了 不折腾了 就用dev 什么都自己手写 这样 考场上就啥也不怕了
//进制转换这块pat都是简单题

int main(){
int a[5],b[5],c[5],carry;
scanf("%d.%d.%d",a+1,a+2,a+3);
scanf("%d.%d.%d",b+1,b+2,b+3);
c[3]=(a[3]+b[3])%29;
carry=(a[3]+b[3])/29;
c[2]=(carry+a[2]+b[2])%17;
carry=(carry+a[2]+b[2])/17;
c[1]=carry+a[1]+b[1];
printf("%d.%d.%d",c[1],c[2],c[3]);
return 0;
}