1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where ​​M[i]​​​ (≤100) is the total number of people that ​​user[i]​​​ follows; and ​​user_list[i]​​​ is a list of the ​​M[i]​​​ users that followed by ​​user[i]​​. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K ​​UserID​​'s for query.

Output Specification:

For each ​​UserID​​, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

BFS遍历图  求限定层次内结点个数。注意是转发次数不是level层内所有结点的个数,也即自己不算,BFS遍历结果num要num-1. 输入的是第i号用户关注的其他用户编号id,也即id->i  而非i->id    也即表示id能走到i(不能说明i能走到id.  id发的微博i能看到) 。剩下的没什么难度了,就是细心.BFS一次过,比1034那题仁慈多了

#include<bits/stdc++.h>
using namespace std;

const int N=1010;
int n,level;
vector<int> Adj[N];

int layer[N]={0};//layer[i] i号人员的层数
bool vis[N]={0};

int bfs(int id){
queue<int> q;
q.push(id);
vis[id]=true;//千万别忘了
// cout<<id<<": "; //BFS输出 dbug很好
int num=0;
while(!q.empty()){
int top=q.front();
q.pop();num++;//第一个入队的首发者也包含在内了 所以多了1 最后应该返回num-1
// cout<<top<<" ";
if(layer[top]<level){
for(int i=0;i<Adj[top].size();i++){
int j=Adj[top][i];//下一个能走到的结点
if(!vis[j]){
vis[j]=true;
layer[j]=layer[top]+1;//层数
q.push(j);
}
}
}
}
return num-1;
}

int main(){
// freopen("in.txt","r",stdin);
cin>>n>>level;
int m,user;
for(int i=1;i<=n;i++){
scanf("%d",&m);
while(m--){
scanf("%d",&user);
//error写法:Adj[i].push_back(user);//注意 i关注了user 表示user发的i能看到 也即user能走到i
Adj[user].push_back(i);
}
}
int T;
cin>>T;
while(T--){
cin>>user;
memset(layer,0,sizeof(layer));
memset(vis,0,sizeof(vis));
printf("%d\n",bfs(user));
}

return 0;
}