1086 Tree Traversals Again (25 point(s))

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

PAT 甲级 1086  Tree Traversals Again_1086


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

经验总结:

这一题,实际上题目已经告诉你二叉树的前序序列以及中序序列,然后求后序序列就可以啦~  理解题目意思,就没什么难度了~中间可以不用建树,直接根据前序与中序得出后序序列,这样应该可以节省一点时间~

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;
const int maxn=40;
int in[maxn],post[maxn],pre[maxn],n,p,postlen=0;
void convert(int inL,int inR,int preL,int preR)
{
if(preL>preR)
return ;
int k;
for(k=inL;k<=inR;++k)
if(in[k]==pre[preL])
break;
convert(inL,k-1,preL+1,preL+k-inL);
convert(k+1,inR,preL+k-inL+1,preR);
post[postlen++]=pre[preL];
}
int main()
{
char s[7];
int t,inlen=0,prelen=0;
stack<int> q;
scanf("%d",&n);
for(int i=0;i<n+n;++i)
{
scanf("%s",s);
if(strcmp(s,"Push")==0)
{
scanf("%d",&t);
q.push(t);
pre[prelen++]=t;
}
else
{
in[inlen++]=q.top();
q.pop();
}
}
convert(0,inlen-1,0,prelen-1);
for(int i=0;i<postlen;++i)
printf("%d%c",post[i],i<postlen-1?' ':'\n');
return 0;
}