1134 Vertex Cover (25 point(s))

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2]⋯v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line ​​Yes​​​ if the set is a vertex cover, or ​​No​​ if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

经验总结:

 emmmm   其实就是求所给的点能否覆盖所有边,所谓覆盖的意思就是,这个顶点是一条边的其中一个顶点。问题很清楚,最终求得就是所有的边是否被访问到,所以输入时,每个顶点都存储自己可达的所有边的序号,然后根据所给的顶点集,遍历一遍所覆盖的边,最后判断所有的边是否被遍历完全即可~

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
const int maxn=10010;
const int INF=0x3fffffff;
int n,m,k,a,b,t,Nv;
vector<int> adj[maxn];
bool flag[maxn]={false};
int main()
{
scanf("%d%d",&n,&m);
for(int i=0;i<m;++i)
{
scanf("%d%d",&a,&b);
adj[a].push_back(i);
adj[b].push_back(i);
}
scanf("%d",&k);
for(int i=0;i<k;++i)
{
memset(flag,0,sizeof(flag));
bool f=1;
scanf("%d",&Nv);
for(int j=0;j<Nv;++j)
{
scanf("%d",&t);
for(int x=0;x<adj[t].size();++x)
flag[adj[t][x]]=true;
}
for(int j=0;j<m;++j)
if(flag[j]==false)
{
f=0;
break;
}
printf("%s\n",f?"Yes":"No");
}
return 0;
}