1097 Deduplication on a Linked List (25 point(s))

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where ​​Address​​​ is the position of the node, ​​Key​​​ is an integer of which absolute value is no more than 10​4​​, and ​​Next​​ is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

经验总结:

emmmm  静态链表排序常规题,这一题是将冗余的结点按照原来在链表中的顺序单独成链,只要善用标号的技巧,对于不同类型的结点进行不同的标号,然后根据标号排序,最后输出就行啦~

AC代码

#include <cstdio>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=100010;
const int INF=0x3fffffff;
bool flag[10010]={false};
struct node
{
int address,next,key,level;
node()
{
level=INF;
}
}Node[maxn];
bool cmp(node a,node b)
{
return a.level<b.level;
}
int main()
{
int start,n,id;
scanf("%d%d",&start,&n);
for(int i=0;i<n;++i)
{
scanf("%d",&id);
Node[id].address=id;
scanf("%d%d",&Node[id].key,&Node[id].next);
}
int p=start,num=0,total=0;
while(p!=-1)
{
if(flag[abs(Node[p].key)]==false)
{
Node[p].level=num++;
flag[abs(Node[p].key)]=true;
}
else
Node[p].level=n+total;
p=Node[p].next;
++total;
}
sort(Node,Node+maxn,cmp);
for(int i=0;i<num;++i)
{
printf("%05d %d ",Node[i].address,Node[i].key);
if(i<num-1)
printf("%05d\n",Node[i+1].address);
else
printf("-1\n");
}
for(int i=num;i<total;++i)
{
printf("%05d %d ",Node[i].address,Node[i].key);
if(i<total-1)
printf("%05d\n",Node[i+1].address);
else
printf("-1\n");
}
return 0;
}