1063 Set Similarity (25 point(s))

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

经验总结:

这一题,使用set实现比较简单一些,当然,使用map应该也可以实现(不过并没有测试过是否会超时),需要注意,在进行查找共同元素时,不能再使用一个set将两个set集合放进去计算,因为查询,肯定有可能很多,就很有可能会超时,这里直接遍历其中一个,找出相同元素的个数,然后根据之间的关系就能计算相似度啦~

AC代码

#include <cstdio>
#include <algorithm>
#include <set>
using namespace std;
const int maxn=100010;

int main()
{
set<int> s[50];
int n,m,t,a,b,k;
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%d",&m);
for(int j=0;j<m;++j)
{
scanf("%d",&t);
s[i].insert(t);
}
}
scanf("%d",&k);
for(int i=0;i<k;++i)
{
scanf("%d %d",&a,&b);
int cnum=0,tnum=0;
for(set<int>::iterator it=s[a-1].begin();it!=s[a-1].end();++it)
{
if(s[b-1].count(*it)!=0)
++cnum;
else
++tnum;
}
printf("%.1f%%\n",cnum*1.0/(s[b-1].size()+tnum)*100);
}
return 0;
}