1153 Decode Registration Card of PAT (25 point(s))

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely,​​T​​​ for the top level,​​A​​​ for advance and​​B​​ for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of​​yymmdd​​;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤104) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format ​​Type Term​​, where

  • ​Type​​​ being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding​​Term​​ will be the letter which specifies the level;
  • ​Type​​​ being 2 means to output the total number of testees together with their total scores in a given site. The corresponding​​Term​​ will then be the site number;
  • ​Type​​​ being 3 means to output the total number of testees of every site for a given test date. The corresponding​​Term​​ will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line ​​Case #: input​​​, where ​​#​​​ is the index of the query case, starting from 1; and ​​input​​ is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is,​​CardNumber Score​​. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format​​Nt Ns​​​ where​​Nt​​​ is the total number of testees and​​Ns​​ is their total score;
  • for a type 3 query, output in the format​​Site Nt​​​ where​​Site​​​ is the site number and​​Nt​​​ is the total number of testees at​​Site​​​. The output must be in non-increasing order of​​Nt​​​'s, or in increasing order of site numbers if there is a tie of​​Nt​​.

If the result of a query is empty, simply print ​​NA​​.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

经验总结:

emmmm  第一遍直接AC,这一次就。。。一个段错误,一个超内存,很尴尬- -|||所以考试能不能AC,还是看状态的= =,这一题,实际上难的点,就在第三种类型的存储上面,可以肯定要用映射(map或者unordered_map),至于map的类型是什么,这就是一个问题,map<string,map<int,int> >就可以了,因为只要存储考场号以及人数,但是,这种情况没法在查询前进行排序,当然,也没必要进行,在查询时,针对查询的考场,建立一个vector<pair<int,int> > 收集其中的考场号和人数,然后再进行排序,最后输出就行啦~

AC代码

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <unordered_map>
using namespace std;
int m,n;
struct student
{
int score;
char id[15];
student(char a[],int s)
{
strcpy(id,a);
score=s;
}
};
struct school
{
int tscore,tnum;
school():tscore(0),tnum(0){}
}sch[1000];

bool cmp1(student a,student b)
{
if(a.score!=b.score)
return a.score>b.score;
return strcmp(a.id,b.id)<0;
}

bool cmp2(pair<int,int> a,pair<int,int> b)
{
if(a.second!=b.second)
return a.second>b.second;
return a.first<b.first;
}
unordered_map<int,int> rmp;
unordered_map<string,unordered_map<int,int> > mp;
vector<student> stu[3];
int main()
{
char temp[15],sno[8];
int score,no,f;
rmp['B']=0;rmp['A']=1;rmp['T']=2;
scanf("%d%d",&n,&m);
for(int i=0;i<n;++i)
{
scanf("%s%d",temp,&score);
stu[rmp[temp[0]]].push_back(student(temp,score));
for(int j=1;j<4;++j)
sno[j-1]=temp[j];
sno[3]='\0';
sscanf(sno,"%d",&no);
++sch[no].tnum;
sch[no].tscore+=score;
for(int j=4;j<10;++j)
sno[j-4]=temp[j];
sno[6]='\0';
++mp[sno][no];
}
for(int i=0;i<3;++i)
sort(stu[i].begin(),stu[i].end(),cmp1);
for(int i=1;i<=m;++i)
{
scanf("%d %s",&f,&temp);
printf("Case %d: %d %s\n",i,f,temp);
int level=rmp[temp[0]];
if(f==1)
if(stu[level].size()==0)
printf("NA\n");
else
for(int j=0;j<stu[level].size();++j)
printf("%s %d\n",stu[level][j].id,stu[level][j].score);
else if(f==2)
{
int room;
sscanf(temp,"%d",&room);
if(sch[room].tnum==0)
printf("NA\n");
else
printf("%d %d\n",sch[room].tnum,sch[room].tscore);
}
else
{
if(mp[temp].size()==0)
printf("NA\n");
else
{
vector<pair<int,int> > x;
for(unordered_map<int,int>::iterator it=mp[temp].begin();it!=mp[temp].end();++it)
x.push_back(make_pair(it->first,it->second));
sort(x.begin(),x.end(),cmp2);
for(int j=0;j<x.size();++j)
printf("%d %d\n",x[j].first,x[j].second);
}
}
}
return 0;
}