1028 List Sorting (25 point(s))

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then Nlines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

Experiential Summing-up

This question can be solved easily. But take care that using scanf() and printf() would be faster than using cin and cout in the last test point. That's all~

(The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct student
{
int no,score;
char name[10];
};
int f;
bool cmp(student a,student b)
{
if(f==2&&strcmp(a.name,b.name)!=0)
return strcmp(a.name,b.name)<0;
if(f==3&&a.score!=b.score)
return a.score<b.score;
return a.no<b.no;
}
int main()
{
int n;
vector<student> stu;
scanf("%d %d",&n,&f);
for(int i=0;i<n;++i)
{
student a;
scanf("%d %s %d",&a.no,a.name,&a.score);
stu.push_back(a);
}
sort(stu.begin(),stu.end(),cmp);
for(int i=0;i<stu.size();++i)
{
printf("%06d %s %d\n",stu[i].no,stu[i].name,stu[i].score);
}
return 0;
}