​点击打开链接​​   密码:syuct

Digital Roots

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 1

Times New Roman | Verdana | Georgia

← →

Problem Description


The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.


Input


The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.


Output


For each integer in the input, output its digital root on a separate line of the output.


Sample Input


24 39 0


Sample Output


6 3



思考题,也可以用字符串模拟,但是会很麻烦。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
char s[1005];
while(scanf("%s",s)&&s[0]!='0')
{
int ans=0;
int len=strlen(s);
for(int i=0;i<len;i++)
ans+=s[i]-'0';
if(ans%9==0)
printf("9\n");
else
printf("%d\n",ans%9);
}
return 0;
}


参考网址:

​http://blog.sina.com.cn/s/blog_7f53331d0100r4qq.html​