10000ms

1000ms

256MB

描述

There are N queens in an infinite chessboard. We say two queens may attack each other if they are in the same vertical line, horizontal line or diagonal line even if there are other queens sitting between them.

Now given the positions of the queens, find out how many pairs may attack each other?

输入

The first line contains an integer N.

Then N lines follow. Each line contains 2 integers Ri and Ci

No two queens share the same position.  

For 80% of the data, 1 <= N <= 1000

For 100% of the data, 1 <= N <= 100000, 0 <= Ri, Ci

输出

One integer, the number of pairs may attack each other.

样例输入

5 1 1 2 2 3 3 1 3 3 1

样例输出

10

本来觉得题很复杂,看了一个

原来map可以这样用,受教了。以后的路还有好远。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<map>
using namespace std;
#define ll long long
map<int,int>m1;
map<int,int>m2;
map<int,int>m3;
map<int,int>m4;
int main()
{
int n,a,b,ans=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
ans+=m1[a];
m1[a]++;
ans+=m2[b];
m2[b]++;
ans+=m3[a+b];
m3[a+b]++;
ans+=m4[a-b];
m4[a-b]++;
}
printf("%d\n",ans);
return 0;
}