1667: 好老师


Time Limit: 1 Sec  Memory Limit: 128 MB

[​​Submit​​​][​​Status​​​][​​Web Board​​]

Description


 我想当一个好老师,所以我决定记住所有学生的名字。可是不久以后我就放弃了,因为学生太多了,根本记不住。但是我不能让我的学生发现这一点,否则会很没面子。所以每次要叫学生的名字时,我会引用离他最近的,我认得的学生。比如有10个学生:

A ? ? D ? ? ? H ? ?

 

想叫每个学生时,具体的叫法是:

位置

叫法

1

A

2

right of A (A右边的同学)

3

left of D (D左边的同学)

4

D

5

right of D (D右边的同学)

6

middle of D and H (D和H正中间的同学)

7

left of H (H左边的同学)

8

H

9

right of H (H右边的同学)

10

right of right of H (H右边的右边的同学)


Input


 输入只有一组数据。第一行是学生数n(1<=n<=100)。第二行是每个学生的名字,按照从左到右的顺序给出,以逗号分隔。每个名字要么是不超过3个英文字母,要么是问号。至少有一个学生的名字不是问号。下一行是询问的个数q(1<=q<=100)。每组数据包含一个整数p(1<=p<=n),即要叫的学生所在的位置(左数第一个是位置1)。


Output


 对于每个询问,输出叫法。注意"middle of X and Y"只有当被叫者离有两个最近的已知学生X和Y,并且X在Y的左边。

 


Sample Input


10

A ? ? D ? ? ? H ? ?

4

3

8

6
10




Sample Output


left of D

H

middle of D and H

right of right of H


【分析】


数据比较小,直接找位置就行了,难点就是名字难搞罢了...所以~用map给每个人编个号,就简单了


不得不说stl里的set,vector,map,queue真是非常方便的东西...


【代码】


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

map<int,string>f2;
map<string,int>f1;
int a[10000];

void write2(int j,string x)
{
for (int i=0;i<j;i++) cout<<"left of ";
cout<<x<<endl;
}
void write1(int j,string x)
{
for (int i=0;i<j;i++) cout<<"right of ";
cout<<x<<endl;
}


int main()
{
f2[-1]="?";f1["?"]=-1;
int n;cin>>n;
int t=1;
for (int i=1;i<=n;i++)
{
string x;cin>>x;
if (f1[x]!=0) a[i]=f1[x]; else a[i]=t,f1[x]=t,f2[a[i]]=x,t++;
}
int pp;scanf("%d",&pp);
while (pp--)
{
int x;cin>>x;
if (a[x]!=-1) cout<<f2[a[x]]<<endl;
else
{
int i=x-1,j=x+1;
while ((a[i]==-1|| i<1)&&(a[j]==-1|| j>n)) i--,j++;
if (i>0 && j<=n)
{
if (a[i]!=-1 && a[j]!=-1) cout<<"middle of "<<f2[a[i]]<<" and "<<f2[a[j]]<<endl;
else
if (a[i]!=-1) write1(x-i,f2[a[i]]);
else if (a[j]!=-1) write2(j-x,f2[a[j]]);
}
else
{
if (i<0) write2(j-x,f2[a[j]]);
if (j>n) write1(x-i,f2[a[i]]);
}
}
}
return 0;
}