不可以!



1000 ms  |  内存限制: 65535



1



判断:两个数x、y的正负性。

要求:不可以使用比较运算符,即"<",">","<=",">=","==","!="。




有多组数据,每组数据占一行,每一行两个数x,y。

x、y保证在int范围内。


输出 每组数据输出占一行。

如果两个数是一正一负,输出"Signs are opposite"


如果是同为正或同为负,输出"Signs are not opposot"


如果无法确定,输出"Signs can't be sure"


输出不包括引号


样例输入

1 1 -1 1

样例输出

Signs are not opposot Signs are opposite





一道新型水题。其实我不知道为什么不加#include<stdlib.h>就编译CE,加了就AC了。



#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int main()
{
int x,y;
while(~scanf("%d%d",&x,&y))
{
if(x*y)
{
if(x*y+abs(x*y))
printf("Signs are not opposot\n");
else
printf("Signs are opposite\n");
}
else
printf("Signs can't be sure\n");
}
}