Text Reverse


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17702    Accepted Submission(s): 6717


Problem Description


Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.


 



Input


The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.


 



Output


For each test case, you should output the text which is processed.


 



Sample Input


3 olleh !dlrow m'I morf .udh I ekil .mca


 



Sample Output


Hint


 



Author


Ignatius.L


#include<stdio.h>
#include<string.h>
char s[1002];
int main()
{
int test,i,j,len,k;
scanf("%d",&test);
getchar();
while(test--)
{
gets(s);
len=strlen(s);
for(i=0,k=0;i<len;i++)
{
if(s[i]==' ')
{
for(j=i-1;j>=k;j--)
{
printf("%c",s[j]);
}
printf(" ");
k=i+1;
}
}
for(j=len-1;j>=k;j--)
printf("%c",s[j]);
printf("\n");
}
return 0;
}