Ugly Numbers


Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 20851

 

Accepted: 9248


Description


Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 


Input


Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.


Output


For each line, output the n’th ugly number .:Don’t deal with the line with n=0.


Sample Input


1 2 9 0


Sample Output


1 2 10


Source


​New Zealand 1990 Division I​​,UVA 136


#include<stdio.h>
#include<algorithm>
using namespace std;
int Min(int a,int b,int c)
{
return min(a,min(b,c));
}
int main()
{
int i,n,a[1505];
int x=1,y=1,z=1;
a[1]=1;
for(i=2;i<=1500;i++)
{
a[i]=Min(a[x]*2,a[y]*3,a[z]*5);
if(a[i]==a[x]*2)
x++;
if(a[i]==a[y]*3)
y++;
if(a[i]==a[z]*5)
z++;
}
while(scanf("%d",&n)&&n)
{
printf("%d\n",a[n]);
}
return 0;
}